System requirements

You’ll need modern Ruby (>=2.4) with Bundler, Git, ImageMagick, and GhostScript. You can check your versions with the steps below. If you don’t have current versions for these packages, see our Installation guide.

Check for Ruby:

$ ruby -v
  ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-darwin15]

Check for Bundler:

$ bundler -v
  Bundler version 1.16.1

Check for Git:

$ git --version
  git version 2.19.0

To process images, you will also need to have ImageMagick and Ghostscript installed and functional.

Check ImageMagick:

$ convert -version
  Version: ImageMagick 6.9.9-20 Q16 x86_64 2017-10-15 http://www.imagemagick.org
  Copyright: (c) 1999-2017 ImageMagick Studio LLC

Check Ghostscript:

$ gs -version
  GPL Ghostscript 9.21 (2017-03-16)
  Copyright (c) 2017 Artifex Software, Inc.  All rights reserved.

Table of contents